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A copy of this presentation could be found at 
http://bioinformatics.ai.sri.com/ptools/tutorial/sessions/curation
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Starting Pathway Tools

• Start the software with the Lisp option
• The Lisp console will show up
• At the prompt type (pt) (followed by Enter) to start the graphical 

user interface (GUI)
• If you close the GUI, the Lisp console will continue to run
• Exit by typing (exit)
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Working in a Lisp environment: breaks

• A break shifts the focus from the main GUI to the Lisp console

• To generate a break: BREAK key on your keyboard. If you don’t 

have one, type (break) at the listener pane and hit enter

• When Lisp encounters an unrecognized command, it breaks

• A break is NOT a crash

Lisp presents several
recovery options from a break
Type :cont x where x is the
number of the best option
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Bug reports

If you get a break as a result of a bug, get the evaluation stack by 
typing 
:zo :count :15 at the lisp prompt

Copy the output, and send it
by email to
ptools-support@ai.sri.com
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Pathway Tools in editing mode

The database can be accessed by two distinct modes

• Navigator mode allows no modification of the DB

• Editing mode allows complete modification of the DB

DB

Editing is currently available in Desktop mode only, though online 
editors are being developed

user curator
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Installing an editable PGDB
In order to be able to perform editing, you must
have an editable PGDB installed on your system
(built-in PGDBs can’t be edited).
In the following exercises we will be using the PGDB for Arthrospira platensis NIES-39.

Your installation has this PGDB built-in. To make an editable copy of it:

• Select this PGDB

• File → Save PGDB As…

• Type “Test” for New PGDB ID and click outside that box.

• Click OK and wait for the process to complete.

• You will now have two PGDBs for this organism. Open the one with “Source” listed 

as “User”.
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Saving/undoing changes
The user must save changes explicitly

• File → Save Current DB
or

• Save DB button on upper right corner
or

• ^s

“Undo” is called Revert Current DB in PTools lingo. It only works with 
unsaved changes, and it reverts all unsaved changes (no step-by step 
undo).

Storing databases in MySQL or Oracle enables the following commands:

• List Unsaved Changes in Current DB
• Checkpoint Current DB Updates to File
• Restore Updates from Checkpoint File
• Refresh All Open DBs
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Other editing-related DB commands 
under the File menu

• Create new version for selected DBs (also modifies the default-
version file to have the new version opened automatically)

• Save DB as… (makes a new copy that can be opened in the 
same session as the source PGDB)

• Delete a DB
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Classes and instances are like folders and files

• Instances describe specific objects (e.g.

L-lysine)

• Classes describe groups of biological 

objects (e.g. “an amino acid”)

• Classes can contain other objects, while 

instances can’t

• Every compound 

with an “R” in its structure

should be a class

• Proteins or modified proteins that are 

substrates of MetaCyc reactions are 

always classes
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What’s a frame? And why does it need an ID?

• Every object in the database is a “frame”, and each frame has a unique ID within 
the database. Instance frame IDs are usually assigned automatically and are not 
very meaningful. 

Examples: CPD-23, PWYQT-7, RXN0-555   MONOMER-387   CPLXI-345.

The prefix describes the type of object. Frame names generated in a PGDB other 
than MetaCyc include one or two characters that identify the source database. 

Legacy objects in Pathway Tools (created before current naming standards) 
usually deviate from these guidelines.

• Class frame names are usually created by humans and use language. E.g.
Thioglucosides, Amino-Acid-Biosynthesis.

• Object names include common names and synonyms. They are useful for both 
humans and computer searches. Unlike frame IDs, names may be not unique.
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Printing frame IDs in the Lisp Console

Curation involves working with frame IDs. A convenient way to do 
it is to print them to the Lisp console and copy them from there.
• Right-click on an object name and select Show → Show frame 

name
• Move to the Lisp console and copy the name to the clipboard.
• If collecting multiple names, paste it into a text editor
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The author credit system

Author credit gives you credit for your work.

Associating objects with their author makes 
it easy to find the objects you worked on.

Author credit is not properly stored unless a 
curator frame has been created and 
configured properly.
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Creating curator frame – part 1

• Start by checking if there already is a frame for your 
organization (Tools → Search → Organizations)

• If there isn’t one, create one (File → Create →
Organization).

• Next, create a frame for yourself (File → Create →
Curator) 

• User ID must be longer than 3 characters
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Creating curator frame – part 2
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What sort of objects are usually edited?

The following are just a few examples

• metabolites
• reactions
• pathways
• enzymes: (creating complexes, assigning to correct reactions)
• regulatory information
• transcription units
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The editors

• PGDB Info Editor
• Compound Editor and Compound Structure Editors
• Reaction Editor
• Pathway Editor, Pathway Info Editor
• Signaling Pathway Editor
• Protein Editor and Protein Subunit Structure Editor
• Synonym Editor
• Publication Editor
• Curator/Organization Editors
• Gene Editor
• Isoform/Coding-Segment Editor
• RNA Editor
• Transcription Unit Editor
• Regulatory Interaction Editor
• External Database Editor
• Organism Editor
• Frame Editor
• Ontology Editor
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Invoking the Editors
Creating a new Object:

Use the New command under 
certain top menus, or the Create 
command under the File menu

Right-click

left-click 
on “Edit”

Editing an existing 
Object: 

Right-Click on the 
any clickable name, 
select Edit, then the 
appropriate editor
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Compounds
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The compound editor

• Create or edit a 
compound (but not its 
structure)

• Specify Class
• Common Name and 

Synonyms
• Comments, citations
• Links to other DBs
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• Option 1: if the compound is 
present in ChEBI
(https://www.ebi.ac.uk/chebi/) and 
you enter the link, you can import 
the structure directly from ChEBI

• Option 2: install a freeware 
desktop program such as 
ChemSketch, save structure as 
Mol file, and import into PTools

Entering compound structures

https://www.acdlabs.com/resources/freeware/chemsketch/

https://www.ebi.ac.uk/chebi/
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The Marvin structure editor

• Pathway Tools supports the Marvin 
JS structure editor, produced by 
ChemAxon, which needs to be 
obtained from them.

https://chemaxon.com/products/marvin-js

http://bioinformatics.ai.sri.com/ptools/installation-
guide/released/marvin-js.html

Other compound-related functions

• Exporting to other DBs
• Duplicate Frame and Edit

https://chemaxon.com/products/marvin-js
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The PGDB info editor

To access: go to the PGDB home 

page (File-> Summarize Current 

Database or Organism Set)

Right-click the organism name, and 

choose Edit → PGDB Info Editor

This is the place to:

• Create a comment for the PGDB 
home page

• Specify PGDB authors

• Modify NCBI taxonomy

• Specify a footer

• Set the tier level

• Enter MIGS Data

• Enter Annotation Data
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The synonym editor

Lets you easily edit the 
synonyms and set the common 
name

The more synonyms, the more 
likely users are to find an object
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Correct assignment of reactions to enzymes

After running PathoLogic, some enzymes will be assigned to 
reactions incorrectly. A curator needs to remove incorrect 
assignments and attach correct ones.

Example: gene NIES39_RS19045 (ubiE) was curated by RefSeq as 
bifunctional demethylmenaquinone methyltransferase/2-methoxy-6-
polyprenyl-1,4-benzoquinol methylase UbiE, and thus assigned multiple 
reactions of EC 2.1.1.163, demethylmenaquinone methyltransferase. 
Since cyanobacteria produce plastoquinone and not menaquinone, this can’t 
be true.
Click on the UniProt link and you will find that in fact this is MenG and should 
be assigned as EC 2.1.1.329 (a BLAST search against any cyanobacterium 
would have produced this result as well). This reaction is part of the 
phylloquinol biosynthesis pathway.
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UbiE or MenG?

UbiE/MenG has been assigned 5 incorrect reactions. Each one is 
involved in an incorrectly-predicted pathway. We will

1. Change the gene name to menG
2. Change the enzyme name to demethylphylloquinol

methyltransferase
3. Delete the incorrect pathways
4. Delete the incorrect reactions
5. Attach the enzyme to the correct reaction

Other things to do here (but we won’t today)
1. Import the plastoquinone biosynthesis pathway from MetaCyc
2. Find enzymes known to participate in that pathway and attach 

them to the appropriate reactions
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How enzymatic activities are handled

Each enzymatic activity is defined by a new database object that 
points to an enzyme and a reaction 

enzymatic 
activity frameenzyme reaction

The enzymatic activity object is a frame, like everything else in the 
database. It’s frame ID is in the form ENZRXN-XXX

Enzymatic activities also have a common name and potential 
synonyms (e.g. 2-oxoglutarate synthase)
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Deleting incorrect enzymatic activities

Right-click the enzymatic activity name, and select Edit -> Delete
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Attaching a reaction to an enzyme
To add an enzyme to a reaction: First copy the frame ID of the enzyme, then

• Right click the reaction, choose Edit → Create/Add enzyme and 
paste the ID.

Or
• Copy the frame ID of the reaction, then 
• Right click the enzyme, choose Edit → Add Reaction(s) and paste the 

ID.

Connecting a reaction with a protein will open 
the Protein Editor and require you to enter an 
enzymatic activity name in the editor. More 
about that in the next slides. 
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Proteins
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The protein editor (monomer version)

(protein complex version)
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Protein editor – first tab
For an example of a complex, open CPLX2764-6 in the A. platensis PGDB
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Protein editor - subunits tab (for complexes)

• Edit the copy number of 
each subunit

• Specify UniProt ID or links 
to other databases

• Specify experimental MW 
and any useful info that 
may apply (GO terms, 
features, copy number)
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Protein editor - enzymatic activity tab
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Reactions
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The reaction editor

With the Reaction Editor you 
can:

• Enter or edit a reaction

equation

• Specify EC numbers (official?)

• Enter a common name (if no full 

EC number exists)

• Set Conversion Type

• Specify location information 

(transport, cellular location)

• Specify reaction direction

L-lysine + H2O + O2 = 6-amino-2-oxohexanoate + ammonium + H2O2
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Reaction editor examples

Regular chemical reaction:

L-lysine + H2O + O2 = 6-amino-2-oxohexanoate + ammonium + H2O2

Transport reaction:

first, set reaction type to transport

L-lysine[out] + ATP[in] + H2O[in] = L-lysine[in] + ADP[in] + Pi[in]
(note – unbalanced)

balance, then add reaction locations
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Duplication is bad

Avoid Duplication! Reuse information whenever 
possible

• A PGDB should not describe the same 
biological or chemical entity more than 
once

• You should not recreate an entry already 
present in MetaCyc

• Some tools help prevent the inadvertent 
creation of duplicate compounds and 
reactions

Duplicates can be cute, but should be avoided
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The duplicate checker

Enter a new reaction/compound

No

Is the object 
already present?

Yes, in current PGDB
Yes, in MetaCyc

No action required Delete new object
Delete new object and 
import from MetaCyc
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Compound duplicate checker - import
If the compound duplicate checker catches a duplicated compound 
upon its creation, you can delete the new compound and import 
the MetaCyc compound instead. 
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Compound duplicate checker - merge
If the compound duplicate checker catches an existing 
duplication, you can merge the two compounds, keeping the 
MetaCyc Frame ID. 
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Reuse existing reactions instead of creating duplicates!

If the reaction is already 
present in your PGDB, you 
will see a window like this 
one

You should choose the option 
“Delete”. 

If you want to use the 
reaction in a pathway, press 
“show”, then copy the frame 
ID of the existing reaction
before you press Delete and 
close this window, so you 
could use it later when 
specifying the pathway.
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Import MetaCyc reactions instead of creating duplicates!

If the reaction is already present 
in MetaCyc (but not the current 
PGDB), you will see a window 
like this one

You should choose the option 
“Import”. 

If you want to use the reaction in 
a pathway, copy the frame ID of 
the existing reaction before you 
press the Import button, so you 
could use it later when 
specifying the pathway.
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Pathways
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The pathway info editor

• Class (variant class)
• Common Name
• Synonyms
• Evidence Codes
• Citations
• Summary 
• External Links
• Hypothetical reactions
• Key reaction
• Rate-limiting steps
• Enzymes not in use
• Author credit
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Evidence codes for pathways

http://bioinformatics.ai.sri.com/evidence-ontology/

Experimental evidence codes:

IDA: inferred from direct assay
IEP: inferred from expression pattern
IPI: inferred from physical interaction
TAS: traceable author statement
IGI: inferred from genetic interaction
IMP: inferred from mutant phenotype

Full documentation for an evidence code is 
displayed in the Navigator (click the code icon)

http://bioinformatics.ai.sri.com/evidence-ontology/
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The pathway editor
Graphically create and modify pathways

Reaction Menu: add reactions one by one
Pathway Menu: add  sub-pathways to create a superpathway
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Connecting reactions

Additional Functionality can be 
accessed by right-clicking on 
compounds or reaction lines

(example: L-valine biosynthesis)
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Pathway editor limitations

Complex situations can cause ambiguity:
• reaction directionality not specified
• reaction directionality opposite to 

direction in pathway
• dialog box for disambiguating
• pathway drawn in bizarre arrangement

• Fix:
• try disconnecting reactions, specifying main compounds,  

and adding them in different order

Limitation: a reaction can appear only once
in a pathway.
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Please download “1. Reactions and pathways handout.pdf” from
http://bioinformatics.ai.sri.com/ptools/tutorial/sessions/curation
and complete the exercise before our next Zoom session.

If you run into difficulties or have any questions, contact me at 
ron.caspi@sri.com. I will be happy to answer any questions.

Homework

http://bioinformatics.ai.sri.com/ptools/tutorial/sessions/curation
mailto:ron.caspi@sri.com

	Editing Pathway/Genome Databases I
	Starting Pathway Tools
	Working in a Lisp environment: breaks
	Bug reports
	Pathway Tools in editing mode
	Installing an editable PGDB
	Saving/undoing changes
	Other editing-related DB commands under the File menu
	Classes and instances are like folders and files
	What’s a frame? And why does it need an ID?
	Printing frame IDs in the Lisp Console
	        The author credit system
	Creating curator frame – part 1
	Creating curator frame – part 2
	What sort of objects are usually edited?
	 The editors
	Invoking the Editors
	Slide Number 18
	The compound editor
	Entering compound structures
	The Marvin structure editor
	The PGDB info editor
	The synonym editor
	Correct assignment of reactions to enzymes
	UbiE or MenG?
	How enzymatic activities are handled
	Deleting incorrect enzymatic activities
	Attaching a reaction to an enzyme
	Slide Number 29
	The protein editor
	Protein editor – first tab
	Protein editor - subunits tab (for complexes)
	      Protein editor - enzymatic activity tab
	Slide Number 34
	The reaction editor
	Reaction editor examples
	Duplication is bad
	The duplicate checker
	Compound duplicate checker - import
	Compound duplicate checker - merge
	Reuse existing reactions instead of creating duplicates!
	Import MetaCyc reactions instead of creating duplicates!
	Slide Number 43
	The pathway info editor
	Evidence codes for pathways
	The pathway editor
	Connecting reactions
	Pathway editor limitations
	Slide Number 49

